Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: Vitz Vibrations

  1. #1
    PakWheeler Follow
    shoaib.nabeel's Avatar
    Join Date
    Feb 2013
    Location
    Islamabad
    Age
    34
    Posts
    29
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

  2. #2
    Senior PakWheeler Follow
    dynamicallyStatic's Avatar
    Join Date
    Jul 2008
    Location
    Rawalpindi
    Age
    35
    Posts
    1,290
    Follows
    5
    Following
    0
    Mentioned
    138 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @shoaib.nabeel
    Ref to your *Engine surging*:

    I have a vitz 08 and at very low speeds (around 20kmph), I feel that if i lift the acceleration pedal the car kind of tries to slow down itself (giving a slight jerk). To mantain a slow speed of 20-25, I have to keep the slight pedal pressed. My understanding is that it should keep the momentum on a flat track if i lift the pedal.
    Also, the same behavior is experieced when I am at high speeds (60-70) and apply brakes sloftly to slow down, upon reaching 20-30, it gives that slight jerk again and slows down quickly...
    Not sure if this is an intended feature?
    Changed spark plugs recently, air filter is clean, throttle body is clean.

  3. #3
    PakWheeler Follow
    shoaib.nabeel's Avatar
    Join Date
    Feb 2013
    Location
    Islamabad
    Age
    34
    Posts
    29
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ------------------------

  4. #4
    Senior PakWheeler Follow
    dynamicallyStatic's Avatar
    Join Date
    Jul 2008
    Location
    Rawalpindi
    Age
    35
    Posts
    1,290
    Follows
    5
    Following
    0
    Mentioned
    138 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No overheat, no check engine light. Have taken it to motorway as well, no issues. The issue is only with very low speed as i stated in my query.

  5. #5
    PakWheeler Follow
    amjads98's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Age
    41
    Posts
    102
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    no issues with your car. its normal.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •