Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27
Like Tree1Likes

Thread: Need help for vitz

  1. #1
    PakWheeler Follow
    ali_sh's Avatar
    Join Date
    Oct 2013
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Need help for vitz

    AOA,

    I have vitz 2004 model (old shape) 1000cc, auto, Petrol. From past few months i am facing a problem related to its starting.
    Its starts on 2 short selfs (ignition) OR 1 long self.
    But if i start it just after turning it off it starts normally. However after starting it in any condition it runs smoothly.

    The steps i have taken place to resolve the issue are:

    1. Fuel injectors cleaning (Ultra sonic bath cleaning)
    2. Fuel pump changed
    3. Fuel filter changed
    4. Spark plugs/air filter changed
    5. Coolant temperature sensor changed
    6. Air flow sensor changed
    7. New battery (AGS GL-50)
    8. Fuel Pressure Regulator changed

    But the issue is still there. I don't know what to do now to get rid of this problem. I have already spent much on this but all in vain.

    Hope someone can help me.. Thanks!!


  2. #21
    PakWheeler Follow
    ali_sh's Avatar
    Join Date
    Oct 2013
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Xulfiqar

    Yes checking the fuel pressure is just a guess as i don't have a pressure tester at home.
    I know ideally the pressure should be between 301 - 347 kPa (3.1 - 3.5 kgf/cm2, 44 - 50 psi), but i don't have a pressure tester to test it exactly.

    Ok that's a nice idea, i am going to connect a bulb at the pump terminals and check if it goes off or not while cranking.

  3. #22
    PakWheeler Follow
    ali_sh's Avatar
    Join Date
    Oct 2013
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    is that actually new or a used replacement? and to test pressure you need a pressure gauge.
    Its a new one, i know it looks like a used one. Its made by DENSO, the original one which i replaced was also from the same company.
    I smelled it deeply for any petrol smell to check if its already used or not, but there was no smell, also it was all bright golden from inside whereas mine was all dark from inside.

  4. #23
    PakWheeler Follow
    Equinox1's Avatar
    Join Date
    Sep 2012
    Location
    Karachi
    Posts
    46
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Xulfiqar bhai please clear your inbox

  5. #24
    PakWheeler Follow
    ali_sh's Avatar
    Join Date
    Oct 2013
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Xulfiqar, @capsat

    Finally i have found one sensor that is malfunctioning. Its Crankshaft Position Sensor.

    According to Toyota service manual for vitz it should give resistance values between 985 - 1,600 ohm at -10?C (14?F) to 50?C (122?F)
    but when i tested mine its giving me value 2.19k ohm. So that's the noticeable difference.

    Tomorrow i am going to replace it. Any suggestions to go for a new one or a Kabli one from Bilal Ganj ?


    Part Code: 90919-05043
    Attached Images Attached Images  

  6. #25
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,591
    Follows
    31
    Following
    6
    Mentioned
    1017 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    waiting for result after crank sensor replacement please update
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  7. #26
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,400
    Follows
    131
    Following
    0
    Mentioned
    3988 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    this would also give you really stupid problems like losing base timing and engine knock sometimes. In most cases the car will simply refuse to start.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  8. #27
    PakWheeler Follow
    ali_sh's Avatar
    Join Date
    Oct 2013
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I haven't changed the crank sensor as it wasn't faulty. Checked 4, 5 sensors in market and all were giving me the same resistance value as mine, so they all can't be faulty, it might be the book i am following has the wrong value written.
    Just changed the O rings of the injectors to make sure there is no leakage.

    Now i have given up!!! and adopted the habit of starting the car twice every time..
    Someone told me there a mechanic named Iqbal who works near Chauburji, may be someday i'll pay him a visit to get my car inspected on the scanner.

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •